Routing Information Protocol(RIP)

How to Configure RIP Routing in GNS3

RIP Routing Network Topology:

RIP Network Topology
RIP Network Topology

What is RIP Routing ?
It is open standard protocol.
Classful routing protocol.
Updates are broadcast via 255.255.255.255.
Administrative distance is 120.
Metric is nothing but Hop count.
Maximum Hop counts is 15.
Maximum supported routers 16.
Load Balancing of 4 equal paths.
Used for small organizations.
TWO Types:
1. RIP VER1
2. RIP VER2
Rip Timers:
Update timer every 30 sec, its is used to time between consecutive updates.
Invalid timer 180 sec, it is used to time a router waits to hear updates.
The route is marked unreachable if there is no update during this interval.
Flush timer 240 sec, it is used to time before the invalid route is purged from the routing table
Hold down timer 180 sec, it is used to Specifies the amount of time for which the information about poorer routes are ignored.
Dis Advantages:
It is only supporting classful IP Address.
It is not supporting variable length subnet mask.
Address type is broadcast.
Not supporting manual router summarization.
Not supporting router authentication method.

R1 Router Configuration:
R1#enable
R1#sh ip interface brief

R1 Router Interface Status
R1 Router Interface Status

R1 ROUTER FAST ETHERNET INTERFACE CONFIGURATION:
R1#conf terminal
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1 ROUTER SERIAL INTERFACE CONFIGURATION:
R1(config)#interface serial 0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#exit
R1#sh ip interface brief

R1 Router Interface status
R1 Router Interface status

R1 ROUTER RIP ROUTING CONFIGURATION:
R1#conf terminal
R1(config)#router rip
R1(config-router)#network 192.168.2.0
R1(config-router)#network 192.168.1.0
R1(config-router)#exit
R1(config)#exit
R1 Router Routing Table

R1 RIP Routing Table
R1 RIP Routing Table

R2 Router Configuration:
R2#enable
R2#sh ip interface brief

R2 Router Interface
R2 Router Interface

R2 ROUTER FAST ETHERNET INTERFACE CONFIGURATION:
R2#conf terminal
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2 ROUTER SERIAL INTERFACE CONFIGURATION:
R2(config)#interface serial 0/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#exit
R2#sh ip interface brief

R2 Router Interface Status
R2 Router Interface Status

R2 ROUTER RIP ROUTING CONFIGURATION:
R2#conf terminal
R2(config)#router rip
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.3.0
R2(config-router)#exit
R2(config)#exit
R2 ROUTER ROUTING TABLE:
R2# sh ip route

R2 Routing Table
R2 Routing Table

Watch Video and Learn RIP Routing

Related posts

Leave a Comment