Routing Information Protocol RIP Version 2

How to Configure RIP Version 2 Routing in GNS3

 

Routing Information Protocol RIP Version 2

Rip Version 2 Network Topology
What is RIP Version 2?
It is advanced version of RIP Ver1.
Overcome the RIP Ver1 Problems.
It is one of the distance vector routing protocol.
It support classless routing
support variable length subnet mask.
Every 30 sec routers sending the update packets.
Maximum supported routers 15.
Maximum hop count is 16.
It is used for small organization.
RIP Version 2 Advantages
1. Supporting Classless Routing
2. Supporting Variable Length Subnet Mask.
3. Sends the Subnet mask along with the Routing Updates.
4. Addressing type is multicast.
5. It’s Support Manual Route Summarization.
6. It’s Support Routing Authentication.
RIP Version 2 Configuration Commands
Start RIP Routing Process.
Router(Config)# router rip
Enable RIP version 2 Routing
Router(Config-router)# Version 2
Select Attached Classless Networking Address
Router(config-router)#network network-Address
R1 ROUTER SERIAL INTERFACE CONFIGURATION
#sh ip interface brief
R1 Router Interface Status
R1#conf terminal
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#exi
R1 ROUTER FAST ETHERNET INTERFACE CONFIGURATION
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#exit
R1#sh ip interface brief
R1 Router Interface Status
R1 ROUTER RIP ROUTING CONFIGURATION
R1#conf terminal
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#exit
R1(config)#exit
R1 ROUTER ROUTING TABLE
R1#sh ip route
R1 Router RIP Version 2 Routing Table
R2 ROUTER SERIAL INTERFACE CONFIGURATION
R2#sh ip interface brief
R2 Router Interface Status
R2#conf terminal
R2(config)#interface serial 0/0
R2(config-if)#ip address 10.0.0.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#exit
R2 ROUTER FAST ETHERNET INTERFACE CONFIGURATION
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 172.30.1.1 255.255.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#exit
R2#sh ip interface brief
R2 Router Interface Status
R2 ROUTER RIP ROUTING CONFIGURATION
R2#conf terminal
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.0.0.0
R2(config-router)#network 172.30.1.0
R2(config-router)#exit
R2(config)#exit
R2 ROUTER ROUTING TABLE
R2#sh ip route
R2 Router RIP Version 2 Routing Table

Watch Video and Learn RIP Version 2 Routing

Related posts

Leave a Comment