Open Shortest Path First (OSPF)

OSPF Routing Configuration in GNS3
OSPF Network Topology:-


What is Open Shortest Path First (OSPF) Routing ?
1. Open standard protocol
2. Successor of RIP
3. Classless routing protocol
4. Works with Link State Advertisements
5. Updates are through Multicast (224.0.0.5 )
6. Administrative distance is 110
7. Metric = Cost =108/Bandwidth in bps (CISCO)
OSPF Basic Operations:
Hello packets are sent every 10 seconds to neighbor routers
It is Faster Convergence
Used to Hierarchical design with Multiple Areas
Area 0 is called the backbone area
OSPF Tables:-
It maintains three Tables:-
1. Neighbor Table
Neighbor table contains information about the directly connected ospf neighbor forming adjacency.
2. Database table
Database table contains information about the entire view of the topology with respect to each router.
3. Routing information Table
Routing table contains information about the best path calculated by the shortest path first algorithm in the database table.
Disadvantages of OSPF
It Consumes More Memory and CPU processing
R1 Router Interface Configuration:
R1##sh ip interface brief
R1#conf terminal
1 R1 Router 10.0.0.0 Network Interface Configuration:-
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1 Router 192.168.1.0 Network Interface Configuration:-
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1##sh ip interface brief
2 R1 Router OSPF Routing Configuration:-
R1(config)#ip routing
R1(config)#router ospf 1
R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#exit
R1(config)#exit
View OSPF Routing Table:-
R1#sh ip route ospf
R1#sh ip ospf database
R1#sh ip ospf neighbor
R1#copy running-config startup-config
R2 Router Interface Configuration:
R2##sh ip interface brief
R2#conf terminal
r2-1 R2 Router 10.0.0.0 Network Interface Configuration:-
R2(config)#interface serial 0/0
R2(config-if)#ip address 10.0.0.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2 Router 11.0.0.0 Network Interface Configuration:-
R2(config)#interface serial 0/1
R2(config-if)#ip address 11.0.0.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2 Router 192.168.2.0 Network Interface Configuration:-
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2##sh ip interface brief
r2-2 R2 Router OSPF Routing Configuration:-
R2(config)#ip routing
R2(config)#router ospf 2
R2(config-router)#network 10.0.0.0 0.255.255.255 area 0
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
R2(config-router)#network 11.0.0.0 0.255.255.255 area 0
R2(config-router)#exit
R2(config)#exit
View R2 Router OSPF Routing Tables:-
R2#sh ip route ospf
R2#sh ip ospf database
R2#sh ip ospf neighbor
R2#copy running-config startup-config
R3 Router Interface Configuration:
R3##sh ip interface brief
r3-1 R3#conf terminal
R3 Router 11.0.0.0 Network Interface Configuration:-
R3#conf terminal
R3(config)#interface serial 0/0
R3(config-if)#ip address 11.0.0.2 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3 Router 192.168.3.0 Network Interface Configuration:-
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3##sh ip interface brief
r3-2R3#conf terminal
R3 Router OSPF Routing Configuration:-
R3(config)#router ospf 1
R3(config-router)#network 192.168.3.0 0.0.0.255 area 0
R3(config-router)#network 11.0.0.0 0.255.255.255 area 0
R3(config-router)#exit
R3(config)#exit
View R3 Router OSPF Routing Tables:-
R3#sh ip route ospf
R3#sh ip ospf database
R3#sh ip ospf neighbor
R1#copy running-config startup-config
WATCH AND LEARN  OSPF ROUTING VIDEO:-

Related posts

Leave a Comment