NIM Server Response to the First BOOTP request was not received

NIM Server Response to the First BOOTP request was not received

 

NIM Server Response to the First BOOTP request was not received:
NIM TOPOLOGY
NIM Server Response to the First BOOTP request was not received

When i was start mksysb restoration through AIX NIM server
i got Response to the First BOOTP request was not received error at NIM Client network booting time.

Error 1:Error Message at NIM Client:

Error 1 : Response to the First BOOTP request was not received
then it was start second attempt then also i got same error
Error 2 : BOOTP request retry attempt: 1
So there is not packet received from NIM-Server which are the packet’s related to NIM through installation.

Response to the First BOOTP request was not received
  BOOTP Parameters:
  ----------------
  chosen-network-type = ethernet,auto,rj45,auto
  server IP = 192.168.1.1
  client IP = 192.168.2.2
  gateway IP = 192.168.2.254
  device = /pci@800000020000223/ethernet@0
  MAC address = c 800 15 60 00 00
  loc-code = U78CD.001.D8FH6C7-P1-C3-T1BOOTP request retry attempt: 1Error 2 :
  Response to the First BOOTP request was not receivedBOOTP Parameters:
  ----------------
  chosen-network-type = ethernet,auto,rj45,auto
  server IP = 192.168.1.1
  client IP = 192.168.2.2
  gateway IP = 192.168.2.254
  device = /pci@800000020000223/ethernet@0
  MAC address = c 800 15 60 00 00
  loc-code = U78CD.001.D8FH6C7-P1-C3-T1BOOTP request retry attempt: 1
  TFTP BOOT ---------------------------------------------------
  Server IP.....................192.168.1.1
  Client IP.....................192.168.2.2
  Gateway IP....................192.168.2.254
  Subnet Mask...................255.255.255.0
  ( 1 ) Filename................./tftpboot/NIM-CLIENT
  TFTP Retries..................5
  Block Size....................512
Problem Identification:

In my NIM Master server i was created 3 Network routing,

bash-4.2# lsnim | grep -i Network
  NIM101 networks ent
  VLAN-101 networks ent
  VLAN-102 networks ent
Verify the Network routing:
bash-4.2# lsnim -l VLAN-101
  VLAN-101:
  class = networks
  type = ent
  Nstate = ready for use
  prev_state =
  net_addr = 192.168.1.0
  snm = 255.255.255.0
  routing1 = default 192.168.1.254bash-4.2# lsnim -l VLAN-102
  VLAN-301:
  class = networks
  type = ent
  Nstate = ready for use
  prev_state =
  net_addr = 192.168.2.0
  snm = 255.255.255.0
  routing2 = default 192.168.2.254
Check Tftp and bootp Protocol status in NIM Master
bash-4.2# cat /etc/services | grep -i tftp
  tftp 69/udp # Trivial File Transfer
  tftp 69/tcp # Trivial File Transfer

 Verify if the booth the protocol service running or not.

bash-4.2# cat /etc/services | grep -i bootps
  bootps 67/udp # Bootstrap Protocol Server
  bootps 67/tcp # Bootstrap Protocol Server

Our NIM Master Server all Pre request protocols are running fine. First we have to trace out the NIM Server Packet between NIM Master and NIM Client using tcpdump utility . I was done first ping test it is working file

 NIM Server IP : 192.168.1.1
 NIM Client IP : 192.168.2.2

So this both IP’s are different networks, Ping testing successfully completed

bash-4.2# tcpdump -i en0 dst 192.168.2.2
 listening on en0, link-type 1, capture size 96 bytes
18:48:39.201989 IP NIM-SERVER>NIM-CLIENT:ICMP echo reply, id 0, seq 2, length 24
18:48:39.223358 IP NIM-SERVER>NIM-CLIENT:ICMP echo reply, id 0, seq 3, length 24
18:48:39.244617 IP NIM-SERVER>NIM-CLIENT:ICMP echo reply, id 0, seq 4, length 24
18:48:39.265870 IP NIM-SERVER>NIM-CLIENT:ICMP echo reply, id 0, seq 5, length 24
18:48:39.287134 IP NIM-SERVER>NIM-CLIENT:ICMP echo reply, id 0, seq 6, length 24
18:48:39.308392 IP NIM-SERVER>NIM-CLIENT:ICMP echo reply, id 0, seq 7, length 24
18:48:39.329747 IP NIM-SERVER>NIM-CLIENT:ICMP echo reply, id 0, seq 8, length 24
18:48:39.351016 IP NIM-SERVER>NIM-CLIENT:ICMP echo reply, id 0, seq 9, length 24
18:48:39.372286 IP NIM-SERVER>NIM-CLIENT:ICMP echo reply, id 0, seq 10,length 24
Verify the bootp and tftp packets status:
TFTP and BOOTP PACKETS Not Transferred to NIM Client
18:49:30.149405 IP NIM-SERVER.bootps>NIM-CLIENT.bootpc:BOOTP/DHCP,Reply,length:300
18:50:04.377889 IP NIM-SERVER.bootps>NIM-CLIENT.bootpc:BOOTP/DHCP,Reply,length:300
Problem Identification:

Bootp and Tftp packets was not able to sent/receive between NIM Master and NIM-Client
There is some access control list was blocked at Layer 3 Switch level.
That is the reason i got the “Response to the First BOOTP request was not received” error message at NIM-Client booting time.

Solution:

by default Network switch level this two protocols (tftp and bootp) blocked across the network.
So we have to open tftp and bootp protocols at layer 3 network switch.

Required Port to be open at Layer 3 Switch:

bootps 67 tcp/udp bidirectional
tftp 69 tcp/udp bidirectional

NIM Server      Protocol             Direction      NIM Client
192.168.1.1     bootps 67 tcp/udp    <======>       192.168.2.2
192.168.1.1     tftp 69 tcp/udp      <======>       192.168.2.2
Create Access control List at network switch:

Raise the service request to network team and open the ports between NIM-Server to across the network.
NIM Server Access control list in network switch

Verify the access control list:
R1#sh access-lists 101 | in 192.168.1.1
10 permit tcp 192.168.0.0 0.0.0.255 host 192.168.1.1 range 67 69
20 permit udp 192.168.0.0 0.0.0.255 host 192.168.1.1 range bootps tftp
30 permit tcp host 192.168.1.1 192.168.0.0 0.0.0.255 range 67 69
40 permit udp host 192.168.1.1 192.168.0.0 0.0.0.255 range bootps tftp
Verify the Router routing set-up:
R1#show ip route
 Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
  E1 - OSPF external type 1, E2 - OSPF external type 2
  i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
  ia - IS-IS inter area, * - candidate default, U - per-user static route
  o - ODR, P - periodic downloaded static routeGateway of last resort is not set
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/1

Nim Server network routing

Router Interface Interface configuration:
interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
ip access-group 101 in
ip access-group 101 out
speed auto
full-duplex
!
interface FastEthernet0/1
ip address 192.168.2.254 255.255.255.0
ip access-group 101 in
ip access-group 101 out
speed auto
full-duplex!
access-list 101 permit tcp 192.168.0.0 0.0.0.255 host 192.168.1.1 range 67 69
access-list 101 permit udp 192.168.0.0 0.0.0.255 host 192.168.1.1 range bootps tftp
access-list 101 permit tcp host 192.168.1.1 192.168.0.0 0.0.0.255 range 67 69
access-list 101 permit udp host 192.168.1.1 192.168.0.0 0.0.0.255 range bootps tftp
Result:

Again boot the that NIM client, start the mksysb restoration it will be work.

Related posts

Leave a Comment