DHCP Router Configuration

DHCP NETWORK TOPOLOGY:-

topology

DHCP SERVER CONFIGURATION IN GNS3 USING ROUTER:-
It is one of the Application Layer Protocol.DHCP Protocol is used to provide the static and dynamic IP address allocation to Network servers and clients.
Static IP Allocation:-
This IP allocation method we can configure permanent ip address to the remoter client using client MAC address.
Dynamic IP Allocation:-
This IP allocation we can set the starting and ending IP address range in DHCP server. it will be automatically provide the IP address to clients using priority order.
Options of DHCP Protocol:-
1. DHCPDISCOVER
2. DHCPOFFER
3. DHCPREQUEST
4. DHCPDECLINE
5. DHCPACK
6. DHCPNACK
7. DHCPRELEASE
Advantages:-
DHCP Protocol reduce the IP wastage.
It reduce the Administration work Load.
We can configure our network clients IP address using static and dynamic methods.
MAC binding method used to configure permanent IP address to the clients.

Step by Step Router Configuration:-
View DHCP Router Interface Status:-
R1#sh ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.1.1 YES NVRAM up up
FastEthernet0/1 unassigned YES NVRAM administratively down down
Configure DHCP Router Interface:-
R1#conf terminal
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shu
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#exit
View DHCP Router Interface Status:-
R1#sh ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.1.1 YES NVRAM up up
FastEthernet0/1 unassigned YES NVRAM administratively down down
Configure DHCP Router:-
R1#conf terminal
R1(config)#ip dhcp
R1(config)#ip dhcp pool lan-network
R1(dhcp-config)#default-router 192.168.1.1
R1(dhcp-config)#exit
R1(config)#exit
Save DHCP Router Running Configuration:-
R1#copy running-config startup-config
R1#sh running-config
Building configuration…
!
hostname R1
!
ip dhcp pool lan-network
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
Basic operation of DHCP Protocol:-
Client —>DHCP Server – DHCP DISCOVER via 255.255.255.255 broadcast IP.
Client<—-DHCP Server -Offer the DHCP service to client.
Client —>DHCP Server – Client send the DHCP Request to Server.
Client<—DHCP Server -Router Provide the DHCP IP Address ACK to Client.
DHCP Capture

Related posts

Leave a Comment